MinimumSize Attribute not working with HtmlFieldControl in TFS 2012 - by tfs2012user

Status : 

  Deferred<br /><br />
		The product team has reviewed this issue and has deferred it for consideration at a later time.<br /><br />
		A more detailed explanation for the resolution of this particular item may have been provided in the comments section.

Sign in
to vote
ID 800926 Comments
Status Closed Workarounds
Type Bug Repros 0
Opened 9/16/2013 4:44:57 AM
Access Restriction Public


More details is on the forum page:

In TFS 2010, our HtmlFieldControl Height was set to 1000 and it worked as expected.

We just moved from TFS 2010 to TFS 2012 this week. In TFS 2012, the HtmlFieldControl Height seems to be a constant number and there is no way to change. MinimumSize="(600,1000)" was added to HtmlFieldControl (and also layout) and it only works in Visual Studio and there is no any effect for web access pages. 

With Firefox Inspector, I found that there is a inline 'style="height: 250px;"' for all tabs.

<div id="witc_122" class="richeditor-container propagate-keydown-event" style="height: 250px;">

If I changed 250px to 1000px, I can see the HtmlFieldControl height was updated to what I want.

The following partial html is given for more clues to experts.

<div class="workitemcontrol"><div id="155"><div id="witc_122" class="richeditor-container propagate-keydown-event" style="height: 250px;"><div class="richeditor-toolbar" style="display: block; opacity: 0.35;"><div class="richeditor-toolbar-group"><span class="richeditor-toolbar-button richeditor-toolbar-bold" title="Bold" tabindex="0" unselectable="on"></span><span class="richeditor-toolbar-button richeditor-toolbar-italic" title="Italic" tabindex="0" unselectable="on">

The root cause is where the inline style "style="height: 250px;""  is from.

<div id="witc_122" class="richeditor-container propagate-keydown-event" style="height: 250px;">

Why isn't the MinimumSize value used? 

Do you have any idea on how to fix this issue? 250px is too small! 

Thanks in advance. 
Sign in to post a comment.
Posted by charlesw.reactive on 11/27/2014 at 7:50 PM
Are there any workaround. This is really annoying and hinders usability for web users
Posted by Ewald [MSFT] on 9/18/2013 at 10:30 AM
Thanks for the feedback.

We have a story on our backlog to get parity of the work item form rendering between VS and Web Access. I have added this feedback to the story.

Sorry for not having a better answer.

Ewald Hofman
TFS Program Manager
Posted by Yu [MSFT] on 9/17/2013 at 5:59 AM
Thank you for submitting feedback on Visual Studio and .NET Framework. Your issue has been routed to the appropriate VS development team for investigation. We will contact you if we require any additional information.
Posted by Macy [MSFT] on 9/16/2013 at 4:51 AM
Thank you for your feedback, we are currently reviewing the issue you have submitted. If this issue is urgent, please contact support directly(