Visual studio 2013 freeze and restarts when use "Format selection" in vbhtml file. - by Arild Røksund

Status : 

  Not Reproducible<br /><br />
		The product team could not reproduce this item with the description and steps provided.<br /><br />
		A more detailed explanation for the resolution of this particular item may have been provided in the comments section.

Sign in
to vote
ID 836568 Comments
Status Closed Workarounds
Type Bug Repros 0
Opened 3/19/2014 1:00:22 AM
Access Restriction Public


When I have a set of html (maybe only with @'s code) Visual studio freeze and restarts.
Attached is one file I have this problem with.

Attached is also error messages from event viewer.
Sign in to post a comment.
Posted by Arild Røksund on 6/16/2014 at 12:15 AM
I did not get the same error with the latest version, but the formating on the two lines started with @ was wrong. This is the way it looked the before I clicked on format selection:
@Imports Microsoft.AspNet.Identity
@ModelType ManageUserViewModel
<p class="text-info">You're logged in as <strong>@User.Identity.GetUserName()</strong>.</p>

And after format selection:
@Imports Microsoft.AspNet.Identity@ModelType ManageUserViewModel
<p class="text-info">You're logged in as <strong>@User.Identity.GetUserName()</strong>.</p>

The @Imports and @ModelType is put on the same line.
Posted by Microsoft on 6/13/2014 at 12:25 PM
thanks for your feedback. Can you please try this out on latest updates for VS 2013? we are unable to reproduce this.
Posted by Arild Røksund on 3/21/2014 at 3:37 AM
I've disabled the extentions that I could (or else the button was disabled) but the result was still the same. I've attached ActivityLog.xml file that was produced by VS. I also looked in this file and could not find any references to other than Microsoft code (no extentions...?!)

I've also done some more testing that it seems that the @ModelType "class name" line on top that cause the problem, if I remove that line there is no problem with Ctrl + A (select all markup) and Format Selection.

Posted by Microsoft on 3/20/2014 at 5:49 PM
We are unable to reproduce this issue with the code file you have provided. Do you have any VS extensions installed on the machine? If yes, can you please disable them and try out the format selection and let us know if it still crashes?
Posted by Microsoft on 3/19/2014 at 9:19 PM
Thank you for submitting feedback on Visual Studio and .NET Framework. Your issue has been routed to the appropriate VS development team for investigation. We will contact you if we require any additional information. If you require immediate assistance with this issue, please contact product support at
Posted by Arild Røksund on 3/19/2014 at 2:39 AM
Hi, thanks for quick response. Have uploaded some files using that tool now.

PS. In your comment (or somewhere else) there should be some information about how to use the "Feedback tool" after installed. Had to, take a deep breath, search Google for information about how to start it after installed.
Posted by Microsoft on 3/19/2014 at 1:27 AM
Thanks for your feedback. In order to efficiently investigate and reproduce this issue, we are requesting additional information outlined below.

Could you please give us a dump file so that we can conduct further research?

Visual Studio now has an extension called Microsoft Visual Studio 2013 Feedback Tool, available on the VS gallery(<>)

The extension allows you to
1. upload files
2. collect trace and dump files
3. collect steps while you're repro'ing the issue
4. SQM logs about VS extensions installed
5. System details (in DxDiag output)

Please submit this information to us within 3 business days. We look forward to hearing from you with this information. If you require immediate assistance with this issue, please contact product support at